UCCNC does not recognize license and only opens in DEMO mode

If you have a question about the software please ask it here.

UCCNC does not recognize license and only opens in DEMO mode

Postby Raider192 » Sat Nov 10, 2018 6:26 pm

Hello,
I have ran successfully for some time now and all the sudden when I run UCCNC it will only start up in Demo mode. I made sure my license is in the UCCNC folder on the C: drive and the UC100 driver is up to date. I also re-installed UCCNC. When I open in Demo it doesn't show its licensed to me it says: Demo. The UC100 has a green light only no blue light when its plugged in. Every time I start up UCCNC it asks me to select Demo mode for the type of controller I have. If I select DEMO UC100 it won't come out of E-stop to even run in Demo mode.
Thanks,
Raider192
 
Posts: 13
Joined: Wed May 31, 2017 8:35 pm

Re: UCCNC does not recognize license and only opens in DEMO

Postby Raider192 » Sat Nov 10, 2018 6:44 pm

Well, I rolled back the driver software to a previous version and it worked. I'm running Windows 7 32bit. how can I keep this from happening in the future?
Raider192
 
Posts: 13
Joined: Wed May 31, 2017 8:35 pm

Re: UCCNC does not recognize license and only opens in DEMO

Postby cncdrive » Sun Nov 11, 2018 5:27 am

Our USB driver has our own USB PID (product ID) which means that only our devices using this driver, so I have no idea why Windows updating it when we have not posted any new drivers to Microsoft.
So, Windows should not update that drivers and honestly I have never heard about this kind of problem from anybody, so it is likely to be a unique Windows problem.
I think the best you can do is to ask Microsoft about why is it happening on your Windows.
cncdrive
Site Admin
 
Posts: 2293
Joined: Tue Aug 12, 2014 11:17 pm


Return to Ask a question from support here

Who is online

Users browsing this forum: No registered users and 11 guests