HotKeys Glitch

If you think you've found a bug post it here.

HotKeys Glitch

Postby Vmax549 » Fri Jun 01, 2018 2:13 pm

I found what appears to be a glitch in hotkeys.

IF I set up a hotkey say {F5} to trigger m20932 it works fine.

BUT IF I set up another hotkey {Alt_F5} to trigger button 6333 when I use that hotkey it runs BOTH {F5} and {Alt_F5} at the same time. Both functions activate.

(;-) TP
Vmax549
 
Posts: 1313
Joined: Sun Nov 22, 2015 3:25 am
Location: USA

Re: HotKeys Glitch

Postby dezsoe » Fri Jun 01, 2018 2:17 pm

Yes, it's a known issue with the function keys. Any modifier keys (Alt, Ctrl, Shift, AltGr) works the same with them.
dezsoe
 
Posts: 545
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary

Re: HotKeys Glitch

Postby Vmax549 » Fri Jun 01, 2018 3:45 pm

It is not just a function key problem it is ANY keyboard charector.

{B} and {Alt_B} Runs both functions
{B} and {Ctrl_B} Runs both functions

Are there any plans to fix it ??

(;-) TP
Vmax549
 
Posts: 1313
Joined: Sun Nov 22, 2015 3:25 am
Location: USA

Re: HotKeys Glitch

Postby dezsoe » Fri Jun 01, 2018 3:54 pm

I've tried it now, but only the function keys have this problem. I didn't try B but O as I have Ctrl-O defined and it starts only with Ctrl.

I made one more test. If I define X to a function, it works also with Ctrl-X, Shift-X etc. If I define a function with Ctrl-X then it works only with Ctrl-X. So the problem is more complex. :( I put it on my list of issues.
dezsoe
 
Posts: 545
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary

Re: HotKeys Glitch

Postby Vmax549 » Sat Aug 11, 2018 3:08 pm

Hi Dezoe, Did you ever come up with a solution to fix this problem using alt keys ??

(;-) TP
Vmax549
 
Posts: 1313
Joined: Sun Nov 22, 2015 3:25 am
Location: USA

Re: HotKeys Glitch

Postby dezsoe » Sat Aug 11, 2018 3:52 pm

Hi Terry, No. But it's Balázs who can repair it. Nowadays I use a touchscreen tablet without any keyboard. That's why I made the OSK plugin to work with MDI. :)
dezsoe
 
Posts: 545
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary

Re: HotKeys Glitch

Postby cncdrive » Sun Aug 12, 2018 12:55 pm

Yes, this is a to be fixed issue.
cncdrive
Site Admin
 
Posts: 2264
Joined: Tue Aug 12, 2014 11:17 pm


Return to Report a bug

Who is online

Users browsing this forum: No registered users and 4 guests