Post anything you want to discuss with others about the software.


Postby jtb223 » Mon Dec 18, 2017 4:21 am

I shut down all of my limit/home switches and it looks like it's working again. I had a problem with one of these switches a while ago and I replaced it. Maybe I'll look into proximity sensors.

Anyhow, thank you for you excellent support. You have some great products and unmatched support.

I hope you enjoy the holiday season.

Thanks again,

Posts: 25
Joined: Fri Sep 09, 2016 1:23 am


Postby cncdrive » Mon Dec 18, 2017 10:54 am


You are welcome. It is good to hear that we figured the root of the problem.
To now debug where the noise spike comes from is unfortunately mostly not as easy as figuring out what we figured out so far.
It can be from several sources:

- If you running a VFD with a powerful spindle motor then it is possible that it emitting noise which effects the wiring or BOB etc. It can be that the noise is transfered via the grounding if the ground wiring of the VFD, PSU of the BOB (if any) or if it is grounded at any point is not optimal, if there are ground loops ... or it is also possible that the wiring itself picking up the noise, e.g. if a high voltage high current wire runs together on a long distance with low voltage wires (e.g. limit input wires).

- If you using a chinese breakout board then it is possible that it is poorly designed. I saw a few of them where the manufacturer used buffer ICs without placing decoupling capacitors close to the chip and with high pullup/pulldown capacitance without any RC filtering which things all makes the system more and more noise sensitive. So, it is possible that the breakout board itself it picking and "amplifying" the noise.

- It can be also a malfunction of a limit switch, when it triggers when it does not have to. E.g. if the spring is broken in the switch or a half-broken wire or a half-broken connection to the switch or to the BOB.

It is usually not easy to get to the root for noise and wiring problems. Even measuring is not very easy, because you need to have a scope or logic analyser with trigger and capture functions and even if you will trigger it that will probably not give an immediate and clear answer to how the spike is generated. But mostly doing more measurements and checking through the whole system offers the solution.
Site Admin
Posts: 3303
Joined: Tue Aug 12, 2014 11:17 pm


Postby Nr1madman » Wed May 16, 2018 5:32 pm

Just registered to this forum because I have the same problem!
Balazs I emailed you directly before finding this thread.

Have tried nulling the estop port and pin as sugested earlier in this thread, also without solving anything.
Will try to disable/disconnect home switches too and see if that works :)

For reference I'm using uc300usb 5lpt with firmware 3.0140 and uccnc 1.2047.
Unshielded ribbon cable to Chinese no name bob.
Bob relay is connected to 2.2kw bed with shielded and grounded wire. Shielded wire for the home switches aswell..
Posts: 6
Joined: Wed May 16, 2018 5:20 pm


Postby cncdrive » Thu May 17, 2018 11:51 am

What message do you see in the statuslist when the reset happens?
If you see ext.trigger then it is the e-stop input on the motion controller. If you see limit switch trigger then it is a limit input. If you see nothing then it is from some other source.
Do you have any plugins or macroloops running?
Site Admin
Posts: 3303
Joined: Tue Aug 12, 2014 11:17 pm


Postby Nr1madman » Thu May 17, 2018 3:33 pm

The fault Im getting is always ext e-stop.
Even though I have tried setting e-stop to port 0 and pin 0.
Still same problem even when I disconnect the wires.

I guess it will be some kind of interference, have tried to reroute some wires today and disconnect the vfd from the bob to minimise all sources of interference.

Did an air run after these changes. Cutting air with spindle on I could run 3h's before ext e stop then it happened 3 times over 10minutes. After that I could run for an hour or something like that. Then I tried actually cutting and got ext e-stop after about 40minutes. Did a reset and got a snack. When I got back the controller had lost connection with pc and uccnc shutdown :(
Typical that it should happen when I had loaded up good looking oak
Posts: 6
Joined: Wed May 16, 2018 5:20 pm


Postby cncdrive » Thu May 17, 2018 3:50 pm

Did you apply the settings when you changed the e-stop input port and pins to 0?
The software should not give you an ext.e-stop trigger text on reset if those are 0, because then there is no e-stop input pin is configured.

The cut connection can be due to noise or for USB controllers it can be that in the Windows power management settings the USB suspend function is enabled which let Windows to cut the USB connections any time it thinks you don't need it. Make sure to disable that function.
Site Admin
Posts: 3303
Joined: Tue Aug 12, 2014 11:17 pm


Postby Nr1madman » Thu May 17, 2018 4:06 pm

Yes, that what confusing me. E stop port and pin is saved as 0/0. Checked and double checked after restart even.
But I still get ext e-stop triggered :)

My physical e-stop still stop vfd and drives but nothing happens in software when pressed. Just as expected!

I get that interference might cut usb connection. I have no active power management that might cause troubles.. that was the first thing I checked :)
This is not the big problem as it rarely happens but the ext e-stop fault always happen when running long programs (3d)
Posts: 6
Joined: Wed May 16, 2018 5:20 pm


Postby Nr1madman » Tue May 29, 2018 11:31 am

Have been trying to find the cause of my problem.
Tried changing usb cable between computer and UC300.
Have tried changing the ribboncable to my BOB.
Have tried disconnecting all switches / estop / spindle control and just using the BOB with outputs for the drivers
Have separeted all low voltage cables from mains voltage wires
The problem appears even though VFD is not running
earlier I wrote that this happens when running 3d files but that doesnt seem true anymore.
Have happened alot when profiling aswell now.

What can I try next?

How can uccnc report ext e-stop even when Estop port and pin is set to 0/0 and no cable is connected to the BOB input?

This is confusing :)
Posts: 6
Joined: Wed May 16, 2018 5:20 pm


Postby Robertspark » Wed May 30, 2018 1:09 am

Have you got a sketch of your wiring?

How many power supplies do you have?
Einstein ― “If you can't explain it to a six year old, you don't understand it yourself”
...working my way through the 1000+ ways things don't work to find the one that does
UC400eth, UC300eth, UCCNC v1.2110, Neuron Lite
UCCNC v1.2110 Macro Manual
Posts: 1667
Joined: Sat Sep 03, 2016 4:27 pm
Location: Nr Liverpool, England


Postby Nr1madman » Wed May 30, 2018 5:04 pm

I have followed this schematic for the electrical stuff

Using one 5v dc psu for the bob. Tried this for uc300 aswell but got alot of "connection lost with pc" so for the uc300 I now power it with 5v from pc psu.
One 24v dc psu for switches, relays, fans
One 50v ac psu for the drives
One standard atx pc psu for computer.

All signal wiring that goes out from the controlcabinet is "cy" type with shields connected to star earth.
Star earth is connected to controlcabinet and machine frame aswell.. going to try with new pc tomorrow and see if that helps :)
Posts: 6
Joined: Wed May 16, 2018 5:20 pm


Return to General discussion about the UCCNC software

Who is online

Users browsing this forum: No registered users and 0 guests