UCCNC M10 Laser not turning off on M10 Q0 Command

If you have a question about the software please ask it here.

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby 3d0g » Sat Oct 20, 2018 8:35 pm

Here's what I get running 'Pulse Width Test 0.1mm UCCNC GRID OmniDir Vmax549.txt' as-is through my machine (click image for full-size):

Image
3d0g
 
Posts: 30
Joined: Sat Apr 14, 2018 1:52 am

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby Robertspark » Sat Oct 20, 2018 8:53 pm

mayhem2408 wrote:This does not work. Using S caused the motion to deaccelerate and accelerate at each S change. This produces poor quality with lasers and can even be dangerous at at high power.


I did suspect that it wouldnt work.... But like my strapline . It's just one of the 1000 ways it don't work
Rob
Einstein ― “If you can't explain it to a six year old, you don't understand it yourself”
...working my way through the 1000+ ways things don't work to find the one that does
UC400eth, UC300eth, UCCNC v1.2108, Neuron Lite
UCCNC v1.2108 Macro Manual
Robertspark
 
Posts: 1201
Joined: Sat Sep 03, 2016 4:27 pm
Location: Nr Liverpool, England

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby mayhem2408 » Sat Oct 20, 2018 10:15 pm

3d0g wrote:Here's what I get running 'Pulse Width Test 0.1mm UCCNC GRID OmniDir Vmax549.txt' as-is through my machine (click image for full-size):

Image

I guess you are running in Inches instead of metric. I'll redo the file in inches which is 25.4x smaller and post is shortly
mayhem2408
 
Posts: 52
Joined: Tue Sep 11, 2018 12:06 am

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby 3d0g » Sat Oct 20, 2018 10:17 pm

mayhem2408 wrote:I guess you are running in Inches instead of metric. I'll redo the file in inches which is 25.4x smaller and post is shortly


Yup. Everything seems to line up tho.
3d0g
 
Posts: 30
Joined: Sat Apr 14, 2018 1:52 am

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby mayhem2408 » Sat Oct 20, 2018 11:04 pm

3d0g wrote:
mayhem2408 wrote:I guess you are running in Inches instead of metric. I'll redo the file in inches which is 25.4x smaller and post is shortly


Yup. Everything seems to line up tho.

Because a mm file run an an inchs machine will be 25.4x bigger, any alignment problem will be less noticable. Can you please try run this attached file. It is redone using inches. and should be the correct size.
Attachments
Pulse Width Test 254DPI UCCNC F78.7401.txt
(10.06 KiB) Downloaded 26 times
mayhem2408
 
Posts: 52
Joined: Tue Sep 11, 2018 12:06 am

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby mayhem2408 » Sat Oct 20, 2018 11:06 pm

3d0g wrote:Here's what I get running 'Pulse Width Test 0.1mm UCCNC GRID OmniDir Vmax549.txt' as-is through my machine (click image for full-size):

Image

As you can see from the original image, even on your machine is doesn't line up quite right.
Pulse Width Test.png
Pulse Width Test.png (293 Bytes) Viewed 290 times

Pulse Width Test 4x.png
Pulse Width Test 4x.png (1.24 KiB) Viewed 290 times
mayhem2408
 
Posts: 52
Joined: Tue Sep 11, 2018 12:06 am

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby cncdrive » Sun Oct 21, 2018 12:50 pm

We have just ran a test using your code with UCCNC version 1.2106 with UC100. Feedrate was F2000.
Please see the test results picture in attachment.
The laser module we used has some focus issues which we did not have time to fix now, but it can be seen that there is no shift and no missing lines.
Attachments
39FCBFA5-45C4-4D59-BB34-2E7AC3933584.jpg
cncdrive
Site Admin
 
Posts: 2451
Joined: Tue Aug 12, 2014 11:17 pm

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby Robertspark » Sun Oct 21, 2018 4:48 pm

Balazs, thanks for testing that.

Mayhem, is there capacitors that are being charged somewhere in your circuit that are delaying the laser?

From what I've seen of these circuits before there is a main power supply circuit which provides the bulk of the current to the laser which may be de-energised by the e-stop button / circuit and then the logic side which just fires the MOSFET very fast.
Rob
Einstein ― “If you can't explain it to a six year old, you don't understand it yourself”
...working my way through the 1000+ ways things don't work to find the one that does
UC400eth, UC300eth, UCCNC v1.2108, Neuron Lite
UCCNC v1.2108 Macro Manual
Robertspark
 
Posts: 1201
Joined: Sat Sep 03, 2016 4:27 pm
Location: Nr Liverpool, England

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby cncdrive » Sun Oct 21, 2018 4:54 pm

Hi Rob,

Maybe the 1.2049 has this issue. I'm not sure if it does not if it does not, I did not have the time to test it yet or to look the bug fixes back, but will try to do it on Wednesday as this Monday and Tuesday will be a national holiday here and I will be away.
Anyways it would be interesting to see if the OP could test the same with the UCCNC version 1.2106 to see his results too.
cncdrive
Site Admin
 
Posts: 2451
Joined: Tue Aug 12, 2014 11:17 pm

Re: UCCNC M10 Laser not turning off on M10 Q0 Command

Postby Robertspark » Sun Oct 21, 2018 5:00 pm

Balazs, thanks for doing it, enjoy your break / holiday, as you can see the post was going round in circles and trying everything.
Rob
Einstein ― “If you can't explain it to a six year old, you don't understand it yourself”
...working my way through the 1000+ ways things don't work to find the one that does
UC400eth, UC300eth, UCCNC v1.2108, Neuron Lite
UCCNC v1.2108 Macro Manual
Robertspark
 
Posts: 1201
Joined: Sat Sep 03, 2016 4:27 pm
Location: Nr Liverpool, England

PreviousNext

Return to Ask a question from support here

Who is online

Users browsing this forum: No registered users and 3 guests