tool height probe diving after back off

If you think you've found a bug post it here.

tool height probe diving after back off

Postby thegreatwaldo » Sun Dec 17, 2017 9:58 pm

Hi Balasz
I'm not sure what is happening with my tool height probe. When I press probe the z axis moves down touches the sensor pulls back a little bit comes down again , stops very shortly and then continues down about 27 mm and stops. Any idea what might be wrong ?

Cheers

Andrew
thegreatwaldo
 
Posts: 62
Joined: Tue Sep 06, 2016 8:28 pm

Re: tool height probe diving after back off

Postby cncdrive » Mon Dec 18, 2017 1:44 am

The probe button calls the M31 macro. The macro is coded in the M31 macro file in the UCCNC/Profiles/Macro_Yourprofilename/M31.txt.
Open the probing macro with a text editor and you can then edit the macro freely.
Everything about the probing button action is coded in that macro like if it makes a single or dual probing movement, the probing feedrates, the retract distance etc.
cncdrive
Site Admin
 
Posts: 2297
Joined: Tue Aug 12, 2014 11:17 pm

Re: tool height probe diving after back off

Postby thegreatwaldo » Mon Dec 18, 2017 8:32 am

Hi Balazs

Thanks for that I will check that out.

Andrew
thegreatwaldo
 
Posts: 62
Joined: Tue Sep 06, 2016 8:28 pm

Re: tool height probe diving after back off

Postby Battwell » Tue Dec 19, 2017 10:28 am

i had something like this when i re wrote my original probing code.
i fixed it by making all moves after the first downwards probe move incremental (g91) controlled then by + or - values to the movements
this ensured it could only go the correct direction
never a problem since

a nice touch was to add a "system beep" just after probing- so i knew it had hit the probe
Uc300eth on router and mill
If they say it can't be done- I find a way!
Battwell
 
Posts: 381
Joined: Sun Sep 25, 2016 7:39 pm
Location: South Wales. Uk

Re: tool height probe diving after back off

Postby dezsoe » Tue Dec 19, 2017 12:07 pm

Battwell wrote:a nice touch was to add a "system beep" just after probing- so i knew it had hit the probe

I attached a small buzzer on the probe input. It's very useful! :)
dezsoe
 
Posts: 571
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary


Return to Report a bug

Who is online

Users browsing this forum: No registered users and 5 guests