Save settings button issues

If you think you've found a bug post it here.

Save settings button issues

Postby msimpson99 » Fri Dec 08, 2017 6:08 pm

I have made changes and applied them. When I hit the Save settings button it depresses. It takes a while for it to depress, The change does not take place unless you wait for the button to depress and this can take over a minute. If you exit before the button depresses, the settings don't get saved. The problem is that the difference between pressed and depressed are very subtle.
Posts: 2
Joined: Tue Dec 05, 2017 9:18 pm

Re: Save settings button issues

Postby ger21 » Fri Dec 08, 2017 6:51 pm

If you are running an AV program, like Windows Defender, try adding an exclusion for the UCCNC folder. It should only take a second to save the settings.
UCCNC 2017 Screenset -
Posts: 904
Joined: Sat Sep 03, 2016 2:17 am

Re: Save settings button issues

Postby cncdrive » Fri Dec 08, 2017 7:39 pm

This issue is because an antivirus software like windows defender checking through the file every time the UCCNC writes a key and especially if your computer has slow hard disk access this can slow down the saving process a lot.
We changed the saving method in the UCCNC a few versions back to avoid this issue. The new saving method doing the Save all keys into memory first and then flushing it to the file with a single write cycle, so antiviruses will only check the file once.
Also we've added protection to not let do anything like button presses while saving is ongoing.
It is yet in the test release only though, which you can download from here (1.2047 is the latest test release version): viewtopic.php?f=2&t=240&start=40
Site Admin
Posts: 1739
Joined: Tue Aug 12, 2014 11:17 pm

Return to Report a bug

Who is online

Users browsing this forum: No registered users and 1 guest