bug in tangential mode

If you think you've found a bug post it here.

bug in tangential mode

Postby neptunier » Wed Aug 07, 2019 3:19 pm

hi,
i am using version 1.2109 with the tangential mode. i got it to work but one thing is not working properly. uccnc rotates the knife also when doing a g0 move. i need to take several passes and it changes direction for g1 and g0 move. that costs a lot of time. did i oversee something?

i found out that uccnc needs to home the a axis, it is not sufficient that you zero the a axis in whatever position is appropriate. my workarround is the following: i set my knife in the proper direction. before in the axis setup i made my probe switch as home switch for my a axis. a home switch is not possible in my setup. then i press the probe switch and then press on home a axis. then the arrow in the toolpath window goes into the proper direction and it works. is there a problem with this work arround?

is there somewhere an explanation how to setup the tangential mode and what all the functions do?

thanks,

michael
neptunier
 
Posts: 30
Joined: Sun Dec 09, 2018 4:03 pm

Re: bug in tangential mode

Postby ger21 » Wed Aug 07, 2019 3:32 pm

Always use the latest test release. It looks like there were Tangential changes in a later version.
Gerry
UCCNC 2017 Screenset - http://www.thecncwoodworker.com/2017.html
ger21
 
Posts: 1806
Joined: Sat Sep 03, 2016 2:17 am

Re: bug in tangential mode

Postby neptunier » Wed Aug 07, 2019 3:44 pm

yes i read the change in 1.2110 but it was not correlated to my problem. therefore i was asking before changing my system.
neptunier
 
Posts: 30
Joined: Sun Dec 09, 2018 4:03 pm

Re: bug in tangential mode

Postby dezsoe » Wed Aug 07, 2019 3:58 pm

You can clear the home pin for the A axis and set also A in the homing sequence. Then you set your knife as you need and do the homing. When a home pin is not set then the current state will be set as home position.
dezsoe
 
Posts: 1093
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary

Re: bug in tangential mode

Postby neptunier » Wed Aug 07, 2019 4:03 pm

thanks dezsoe, that worked.
neptunier
 
Posts: 30
Joined: Sun Dec 09, 2018 4:03 pm

Re: bug in tangential mode

Postby neptunier » Thu Aug 08, 2019 8:19 am

i found another thing which is odd. in some of the first lines in the example code the knife is turning arround much more then the curve radius.
i attached the code, you can see that small knife symbol spinning in the gcode view. interestingly only in the first half of the arc.
thanks,
michael
Attachments
bug.tap
(2.02 KiB) Downloaded 192 times
neptunier
 
Posts: 30
Joined: Sun Dec 09, 2018 4:03 pm

Re: bug in tangential mode

Postby cncdrive » Thu Aug 08, 2019 8:36 am

Do not test 1.2109, it is an old development release, please always report bugs only with the latest development release.
We do not act on old development releases bug reports because those bugs were likely been already fixed.
For example there were lots of fixes and changes in the tangential knife function between 1.2109 and 1.2110.
cncdrive
Site Admin
 
Posts: 3307
Joined: Tue Aug 12, 2014 11:17 pm

Re: bug in tangential mode

Postby neptunier » Thu Aug 08, 2019 8:55 am

okay i will try the new version. before reporting i read in the changelog of the new test version but i did not see any changes related to my problems. i did not realize that more bugs were fixed.
thanks,
michael
neptunier
 
Posts: 30
Joined: Sun Dec 09, 2018 4:03 pm

Re: bug in tangential mode

Postby cncdrive » Thu Aug 08, 2019 9:13 am

The tangential knife algorithm was basically fully rewritten between 1.2109 and 1.2110.
It was a brand new function in 1.2108, so it was still new in 1.2109 and we did not think about one thing which is desribed in the new releases log.,
and that issue required to add one more look ahead buffer and because of that we had to rewrite the whole code.
For this reason it does not makes sense at all to test 1.2109, because in 1.2110 there is a fully different algorithm and code.

And also in general it is not adviced to report bugs in old dev. releases, because they likely to be fixed and code changed...
cncdrive
Site Admin
 
Posts: 3307
Joined: Tue Aug 12, 2014 11:17 pm

Re: bug in tangential mode

Postby neptunier » Thu Aug 08, 2019 9:44 am

i installed the newest version and the last bug dissappeared, great.
however the knife still turns in direction of the g0 positioning move, goes to the position, turns then in direction for the g1/g2/g3 move. in my opinion the turning of the knife for the g0 moves is wasted time or do i overlook something.

thanks for your help,
michael
neptunier
 
Posts: 30
Joined: Sun Dec 09, 2018 4:03 pm


Return to Report a bug

Who is online

Users browsing this forum: No registered users and 1 guest

cron