Why does my Web Browser complain about UCCNC software forum?

If you think you've found a bug post it here.

Why does my Web Browser complain about UCCNC software forum?

Postby LBayZG » Sun Apr 29, 2018 8:33 pm

For the last few weeks, my web browser (FireFox 59.0.2) has started complaining when I attempt to login to this forum.

I get
This connection is not secure. Logins entered here could be compromised.


While I am not worried if my UCCNC forum password gets stolen, it's not as if I've posted my credit card info here, it is annoying.

Has anyone else experienced this? Or is my computer just being 'difficult'?

PS: I am running the Firefox from Linux Ubuntu 16.04.
LBayZG
 
Posts: 37
Joined: Mon Jan 09, 2017 1:14 am

Re: Why does my Web Browser complain about UCCNC software fo

Postby cncdrive » Sun Apr 29, 2018 10:01 pm

Browsers complaint when you opening websites using http protocol.
http protocol is not using encryption for data transfer and so your data could be stolen if for example somebody hacked into your computer and can view your ethernet traffic.
The newer and encrypted protocol is https which transfers datas between the server and client and vica versa via encrypted packets, so your data is safe. Even if somebody can watch your data traffic the data is encrypted, so they still can't understand the data, because they do not have the key to decrypt it.

We have implemented https protocol on our website including our forum, so you may open the forum with https protocol instead of http if you don't want your browser to complain.
Simply open it as: https://forum.cncdrive.com
cncdrive
Site Admin
 
Posts: 2375
Joined: Tue Aug 12, 2014 11:17 pm


Return to Report a bug

Who is online

Users browsing this forum: Bing [Bot] and 4 guests