My setup using multiple HDBB2 BOBs

This Section is for users to discuss hardware

My setup using multiple HDBB2 BOBs

Postby Derek » Fri Sep 22, 2017 4:05 pm

After spending cubic dollars on different "all in one" BOBs I finally made the decision to try multiple HDBB2's. The biggest problem I had with other boards was they weren't able to natively work with the error reporting on the DG4S drives. The HDBB2 does this very well. I'm using a UC-300ETH, LPT5 with ribbon cables to the HDBB2's.
I'm using 2 of these relay boards. one for each HDBB.
https://www.amazon.com/gp/product/B00VJ ... UTF8&psc=1

Image

I have a 16 pin ribbon from the analog port on the LPT5 to a RJ45 BOB. I'm using 2 pins on the BOB for the 0-10V for the spindle speed control and 3 others for the CW, CCW and 24V from the VFD. These are routed through 2 of the relays.

I have another RJ45 BOB that is for the spindle encoder input. I'm running this directly into port 4 on the LPT5 with no opto isolation.

I have push button input controls for 7 functions wired into the HDBB2's. I don't use homing switches on this machine.

I have 2 pneumatic solenoid valves. One for the drawbar and one for the Z axis lock. Both are running through the relay boards.

So far everything is running great. No estops from the solenoids. The drives will put UCCNC into e-stop if one of them faults. Charge pump controls a relay that operates the Z axis brake.

I probably should have done this 4 or 5 BOB's ago:)

Derek
Derek
 
Posts: 299
Joined: Mon Sep 05, 2016 9:57 am

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests