Return to part zero after cut

This is the place to talk about and share things related to CNC plasma machines using UCCNC

Return to part zero after cut

Postby Skrotskalle » Wed Dec 30, 2020 6:16 pm

I have a annoying problem I hope someone can help me with.
After finishing a cut the torch returns to home position (machine X and Y zero). This is really annoying, since I use a watertable and when cutting on a smaller sheet on the middle of the table, the torch will run over uncovered part of the table when the post flow is running splashing water all over.

I am running the latest development version of UCCNC with the Neuron plugin and a NeuronLite THC.

Is there a setting some where to choose between return to part zero or machine zero?
Marcus
Skrotskalle
 
Posts: 6
Joined: Wed Dec 30, 2020 5:46 pm

Re: Return to part zero after cut

Postby ger21 » Wed Dec 30, 2020 6:53 pm

The machine goes where the g-code tells it to go, so this would be a setting in your CAM software.
Gerry
UCCNC 2017 Screenset - http://www.thecncwoodworker.com/2017.html
ger21
 
Posts: 1992
Joined: Sat Sep 03, 2016 2:17 am

Re: Return to part zero after cut

Postby Skrotskalle » Wed Dec 30, 2020 7:48 pm

Here is the g-code from a small part I cut today. I am using Sheetcam by the way.
Last entry is M05 M30 and the there is no move command after that. So why does it return to home position?

N0010 (Filename: Kantvik verktygshållare.tap)
N0020 (Post processor: NeuronThcUccncPost.scpost)
N0030 (Date: 30/12/2020)
N0040 G21 (Units: Metric)
N0050 G53 G90 G91.1 G40
N0060 F1
N0070 S500
N0080 (Part: Kantvik verktyghållare)
N0090 (Operation: Inside Offset, Hål, T13: Standard - Stål - 6 mm - 45 A)
N0100 G00 X14.4948 Y203.0052
N0110 M206 (THC off)
N0120 M205
N0130 M03
N0140 G03 X14.4948 Y203.0052 I3.0052 J-3.0052 F858.0
N0150 M205 (THC on)
N0160 M206 (THC off)
N0170 M05
N0180 G00 Y46.9948
N0190 M206 (THC off)
N0200 M205
N0210 M03
N0220 G03 X14.4948 Y46.9948 I3.0052 J3.0052
N0230 M205 (THC on)
N0240 M206 (THC off)
N0250 (Operation: Outside Offset, DEFAULT, T13: Standard - Stål - 6 mm - 45 A)
N0260 M05
N0270 G00 X-0.7500 Y-6.0000
N0280 M205
N0290 M03
N0300 G01 Y0.0000 F1430.0
N0310 Y253.3750
N0320 G03 X-3.3750 Y250.7500 I-2.6250 J0.0000
N0330 G01 X28.3750
N0340 G03 X25.7500 Y253.3750 I0.0000 J2.6250
N0350 G01 Y-3.3750
N0360 G03 X28.3750 Y-0.7500 I2.6250 J0.0000
N0370 G01 X0.0000
N0380 X-6.0000
N0390 M05
N0400 M05 M30
Marcus
Skrotskalle
 
Posts: 6
Joined: Wed Dec 30, 2020 5:46 pm

Re: Return to part zero after cut

Postby Robertspark » Wed Dec 30, 2020 8:27 pm

have a look in your M30 macro

My neuron M5 is as follows:
Code: Select all
int time = 0;
exec.Stopspin();
while(exec.GetLED(493))   //wait torch retract
{
   if(++time == 50)   //if more then 5 seconds torch will not retracted, return
   {
      return;
   }
   exec.Wait(100);
}


My neuron M30 is as follows:
Code: Select all
//M30, this code is executed on M30 after program end and file rewind

i.e. it is default / not been edited.
Robertspark
 
Posts: 1821
Joined: Sat Sep 03, 2016 4:27 pm

Re: Return to part zero after cut

Postby Skrotskalle » Thu Dec 31, 2020 8:28 am

Just checked the marcos and they are the same as yours. They have not been edited.
Marcus
Skrotskalle
 
Posts: 6
Joined: Wed Dec 30, 2020 5:46 pm

Re: Return to part zero after cut

Postby beefy » Thu Dec 31, 2020 9:16 pm

Hi Marcus,

I single stepped through your code in the demo version of UCCNC and it did exactly what the gcode told it to do.

I can't find a setting in UCCNC that would make the axes return to zero after the gcode is complete.

Maybe try single stepping your gcode doing a dry run (torch not on) and see if it still happens. I'm wondering if this is something to do with the Neuron plugin.
beefy
 
Posts: 422
Joined: Mon Sep 05, 2016 10:34 am

Re: Return to part zero after cut

Postby Skrotskalle » Sat Jan 02, 2021 9:46 am

beefy wrote:Hi Marcus,

I single stepped through your code in the demo version of UCCNC and it did exactly what the gcode told it to do.

I can't find a setting in UCCNC that would make the axes return to zero after the gcode is complete.

Maybe try single stepping your gcode doing a dry run (torch not on) and see if it still happens. I'm wondering if this is something to do with the Neuron plugin.


I will try this later. I am also thinking it might have something to do with the Neuron plugin. Because I did not have this issue before switching to the NeuronLite THC and Neuron plugin.
I will shot Andrew an email if he doesn't chime in here.
Marcus
Skrotskalle
 
Posts: 6
Joined: Wed Dec 30, 2020 5:46 pm

Re: Return to part zero after cut

Postby shad » Sun Jan 03, 2021 7:46 pm

Hello!
Your code is executed as it should. There is no return to part zero. M30 just rewind gcode file.
The plugin doesn't do that either.
You can send me the profile file, I'll check it myself.
-- Andrew
UC400ETH
UC300ETH-5LPT
NEURON Lite THC
http://neuroncnc.com/
shad
 
Posts: 324
Joined: Thu Sep 15, 2016 5:23 pm

Re: Return to part zero after cut

Postby Skrotskalle » Mon Jan 04, 2021 5:26 pm

Here is my profile.
Attachments
NeuronPlasma.pro
(38.46 KiB) Downloaded 67 times
Marcus
Skrotskalle
 
Posts: 6
Joined: Wed Dec 30, 2020 5:46 pm

Re: Return to part zero after cut

Postby shad » Tue Jan 05, 2021 2:16 pm

I am run with your profile - no return to the part zero.
But I see in the macroloop you have a M25100 macro. Have not this on my machine, but You need to check what the macro is and what it does.
Also I think 20.269 pulses in mm value is low. Try to setup microstep value for the stepper drivers for have 200-300 pulses in mm.
In any case email me and I can login to your machine for help too.
-- Andrew
UC400ETH
UC300ETH-5LPT
NEURON Lite THC
http://neuroncnc.com/
shad
 
Posts: 324
Joined: Thu Sep 15, 2016 5:23 pm

Next

Return to CNC Plasma

Who is online

Users browsing this forum: No registered users and 1 guest

cron