UCCNC Skipping M5 Command On Leadout Line

This is the place to talk about and share things related to CNC plasma machines using UCCNC

UCCNC Skipping M5 Command On Leadout Line

Postby RMW2019 » Mon Dec 07, 2020 1:06 am

uccnc.png
Hello evryone. Sorry my first post here is a question but I am totally stumped. I have noticed on a couple of occasions that UCCNC skips the M5 torch off command when leading out of a boundary and going to the next. Attached you will see a screen grab of the screen. This instance is between the last inside boundary and the outer perimeter. You can see the M5 callout but the torch did not switch off causing the rapid move to the outer perimeter to be though cut. This has happened 2 other times and seems to be random but rerunning the program it does the same thing. Is there a setting (look ahead or other) that can be adjusted to remedy this? Thanks in advance for any light you guys may shed!
RMW2019
 
Posts: 1
Joined: Sun Dec 06, 2020 12:15 am

Re: UCCNC Skipping M5 Command On Leadout Line

Postby cncdrive » Mon Dec 07, 2020 7:34 am

The M5 command is aszncronous to the motion which means that when there is an M5 command then the controller waits for the motion to end emptying the motion buffer and then executing the M5 command and then continuing to execute the g/code program.
So, it cannot be the lookahead problem.

I don!t remember that anybody reported any issues with the M3^M5 switching with any versions of the UCCNC, so I doubt that it is a software problem.
cncdrive
Site Admin
 
Posts: 3696
Joined: Tue Aug 12, 2014 11:17 pm


Return to CNC Plasma

Who is online

Users browsing this forum: No registered users and 1 guest